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A. PR MANAGEMENT DASHBOARD 

 
 

1. EXCEL DATA ENTRY APPLICATION 

 
1.1 I receive an error message when I try to run any macro or to export SR sheets. 

 
This error usually appears when the user clicks on any button that has a macro assigned to 
it.  
 
The user usually receives an error message in a pop up window that might say: 

 Automation error 
 Can’t find project or library 
 Missing Visual Basic library 
 Compile error in hidden mode 

 
To solve the message the file MSCOMCTL.OCX needs to be registered. Please follow the 
steps below: 
 
1. Check if the system where the error appears is a 32 or 64 bits machine. You may check 

this by going to “Control Panel” -> “System” 
2. Open the Data entry tool 
3. Go to “Developer” tab -> select “Visual Basic”. If the “Developer” tab doesn’t appear in 

the top bar, go to “File” -> “Options” -> “Customize Ribbon” and check the “Developer” 
tab on the right column) 

4. Double click on “PR data entry tools” (left column) 
5. Enter the password 
6. Click on “Tools” -> “References”. If the “References” menu item is grey, click on “Run” 

and “Reset” 
7. In the “References”, you will see one ticked reference starting with the word “MISSING” 
8. Click on “Browse” 
9. If the machine is 32-bit, enter C:\windows\System32\MSCOMCTL.OCX in the “File 

name” box and “Files of type” select “All files”. If the machine is 62-bit, enter 
C:\windows\SysWOW64\MSCOMCTL.OCX in the “File name” box and “Files of type” 
select “All files”. Click “Open” 

10. A new reference should have appeared, make sure you uncheck the one starting with 
“Missing” 

11. Click “OK” and close the window 
12. Save and close VB window 

 
If an error message appears saying “Error loading dll”, please fully disable the macros and 
try again. 
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If the issue persists: 
Ensure that you are using a 32 bit version of Microsoft Office and re-register the new OCX 
file:  
 
 1. Click Start, type “CMD”.  
 2. Right-click the “CMD” icon, and then click “Run as Administrator”.  
 3. Depending on your operating system:  

 For 64-bit operating systems, type the following:  
o Regsvr32 /u "C:\Windows\SysWOW64\MSCOMCTL.OCX" 
o Regsvr32 "C:\Windows\SysWOW64\MSCOMCTL.OCX"  

 For 32-bit operating systems, type the following:  
o Regsvr32 /u "C:\Windows\System32\MSCOMCTL.OCX" 
o Regsvr32 "C:\Windows\System32\MSCOMCTL.OCX" 

 

1.2 I have Windows 2007 and Excel crashes when I try to create SR/PR sheets 

(even after checking the missing libraries). 

 
If: 

 Windows 2007 
 Excel crashes when trying to create SR/PR sheets 
 All steps from issue 1.1 with missing libraries have been followed 

 
Solution: Please download and install SP3 for Office. 

 

1.3 “Setup” sheet shows 0 or 1 instead of “tick” or “X”. 

 
To solve this conditional formatting issue: 
1. Go to “Review” -> “Unprotect Sheet” 
2. Right click on C5 (or any cell where the format is right), select the format painter and 

then click on the cell that has the issue. This will copy the format. 
3. Go to “Review” -> “Protect Sheet” 
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1.4 The following error message appears when using the Excel file: "Your 

organization's policies are preventing us from completing this action for you. 

For more info, please contact your help desk".  

 

 
This error usually appears when the user clicks on any button and it is caused when 
Internet Explorer has been uninstalled.  
 
To fix the issue, please install Internet Explorer. 
 

1.5 When I try to upload the SR file, the following error message appears: 

“Security problem”. 

 
If the error “Security problem” appears when trying to upload a SR file, that means that 
there was a change in the indicator mapping in the Data Master tool. This change happened 
after the SR file was exported.  
 

1.6 Error importing SR data entry sheet  

 
This error may occur because the name of the SR tab in the SR data entry sheet excel 
workbook may have been changed. Changing the SR data sheet’s tab name to match the 
original name entered into the data master will fix this problem. 
 

1.7 VB Error when exporting SR Data entry Sheet 

 
The error “Run-time error 1004” appears when trying to export a SR Data Entry Sheet. 
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Please ensure that there are no formulas into the SR cells. Formulas will prevent the code 
from executing. 
 

 
 

2. VISUALIZATION 

 

2.1 When the “Compliance indicators” option is selected, the colours that appear 

as red and green do not match the values. 

 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
This is one of the most frequent issues while using the dashboard. For some reason, the 
software requires a refresh to the links of the compliance indicators. This is a software error 
(and the issue is with the .xlf file). To fix this, please follow the below steps: 
 
1. Open the .xlf file using the SAP software. 
2. On the left side select “Object Browser”. 
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3. Activate the “Compliance” sheet by clicking on the “check” sign (the compliance 
indicators will appear on the screen). 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 

4. Display the items on the Compliance Indicators sheet by clicking on the "plus” sign and 
selecting the item "Scorecard 7". 
 

 
 
 
5. Display the properties by clicking on the "Scorecard 7" tab on the right side of the screen. 
You will see the names of the five titles of the table, select the second title and click on the 
first arrow next to “Alert Values”. 
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             6. Then click "Ok" when the "Select a Range" dialogue box appears.  
 

             
 
          7. Repeat this procedure for the next three titles. 
 
 

2.2  All the data is entered into the PRDB data master, yet the dashboard that is 

produced in SAP is blank 

 
This problem has to do with misalignment of dates and periods in the general grant 
information section.  
 
If you change the current period to Q3- 17 and then try and produce a dashboard, the data 
should appear.  
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2.3 All the data is entered into the PRDB data master, but the dashboard doesn’t 

show anything related to PR data 

 
Symptoms: 

 You have filled in or updated all PR related data 

 You export the dashboard but you see: 
o REF or VALUE error under the financial information 
o ‘Commitments with Global Fund’ section doesn’t match the data entered in 

the Data Master file 
o The data on the Programmatic indicators that the PR is reporting doesn’t 

match the data entered in the Data Master File 
 

 
 
 

Solution: 
 
The issue arises when in column J of the tab “PR Setup” there is no data for cells J4 and J5. 
Normally, in the clean master files these cells are filled in with the Actual Worksheet Name. 
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In order to fix the issue: 

 Type “Data PR1’! in cell J4 

 Type “Data SR 001’! in cell  J5 
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B. SR MANAGEMENT TOOL 

 

3. EXCEL DATA ENTRY APPLICATION 

 
3.1 Every time I open or close the SRMT, the password entry message appears.  

 
 
 
 
 
The tool requires at least Excel 2010 32 bits. If opened in a previous version of Excel, you 
will immediately receive a warning that you must enter a password. It is an abnormal 
behavior and this is because SRMT uses code internally to ensure that the sheets are 
properly protected. Excel is sensitive in the way it encrypts passwords and this varies from 
one version to another.  
 
The solution is to press the <Cancel> button or the <ESC> key several times until the 
message disappears. 
 

3.2 When I open the SRTM, the macros don’t run and it allows me to enter  data 

into the protected cells.  

 
This happens when you open the tool on computers with Excel version lower than required. 
The macros do not work correctly and as a result they corrupt the spreadsheets. The same 
issue may appear if the macros are not enabled or when you are using a 64-bit version of 
Excel. 
 
To solve this problem it is important to have installed the correct version of Excel for which 
the SRMT was designed. 
 

3.3 When I enter the dates, they appear in a different format. I enter the dates in 

dd/mm/yyyy format and they appear as dd/mm/aaaa. 

 
Regarding the dates, all tools are sensitive to the language that has been selected upon the 
Excel installation. Excel will automatically translate the months to the selected language. 

 

3.4 During the creation of the annual plan, I copied and pasted several financial 

files into the SRMT tool. When I did this, the links of the source files were 

saved in the SRMT. Now, every time I try to open the tool, I see an error 

message. 

 
Copying and pasting from other files into the SRMT tool is strongly discouraged. As a Super 
configurator, you need to understand which parts of the SRMT are the most vulnerable to 
become corrupted when users attempt to copy and paste data into these sections.     
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The below sections inside the red boxes are the sections where you are allowed to copy and 
paste. Please make sure to paste only the values and not the formulas. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
We suggest that every time you copy and paste data into the SRMT, you follow the below 
steps: 
Copy -> Paste -> Value.  
 
This will prevent you from accidentally copying the links from other files into the SRMT.  

 
Remember, DO NOT copy and paste into the blue color rows. 
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C. CCM SUMMARY TOOL 

 

4. GENERIC QUESTIONS 

 
4.1 I am having difficulties importing the flag into the CCM Summary. What 

should I do? 

 
To make changes to a flag in the CCM Summary, follow the steps: 
 
1. Enter in www.flagpedia.net and type the name of the country in the "search" option. 
 
 
 
 
 
 
 
 
 
 
 

 
 
2. The country flag will appear, right click on the flag and select "Save image as" and save it to 

your computer. 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
3. Open the CCM Summary that you want to modify and click on the flag. 
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4. Display the flag options by clicking on the tab "Image component" that appears on the right 
side of the dashboard. 

 

 
 
5. Select the option “Import”. 
 

 
 

 
6. Select the country flag. 
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7. Then press “OK” and save your work. 

 
 
 
 
 
 
 

 
 
 
 
 
 
 

 

4.2 The information regarding the “last rating” appears correctly for one PR but 

for another PR the message "Please select" appears instead. 

 
This happens when the PR has not assigned a "Last rating" in the data master. We suggest 
to review the PR data master and to make sure that it has the complete information. 
 

4.3 I am in the process of integrating several PR Dashboards into the CCM 

Summary. What happens when PRs have different thresholds in the 

programmatic indicators and are unified in the CCM Summary? 

 
Given that the users of the CCM Summary are all members of the CCM, it was decided that 
the results of the PR indicators will be compared with the thresholds that are regulated by 
the Global Fund. This also applies to financial information. 
 

4.4 Is it possible to increase the number of products in the stock levels section? 

The PR has more than 15 products. 

 
Unfortunately not. The CCM Summary presents the most important information, so we 
suggest that the PR prioritizes the most important products in the first 5 rows of the PR 
Dashboard, so that they appear in the CCM Summary. 
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D. REGIONAL DASHBOARD 

 

5. GENERIC QUESTIONS 
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E. GENERIC QUESTIONS APPLIED TO ALL TOOLS 

 

6. EXCEL DATA APPLICATION 

6.1  Links not found error in the excel data master files  

 
This is a problem that occurs when information was pasted into an excel file but remains 
linked to another excel file, when the links can no longer be found (eg because the file is now 
on a different computer) the error message pops up. To solve try the following:  

1. Break the links  and save the file  
2. If the links cannot be broken for some reason, look at the source of the link:  

 
 
Do a ctrl-f in the whole workbook for this source to find which cells have these links 
as references:  

 
 
And then paste the contents of the cells back into the cells as values.  
 
Save the file.  
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6.2 I have entered and updated data in the Excel Master Data sheet but it doesn’t 

recalculate the new values. 

 
Ensure that the option Formulas -> Calculation Options is set to Automatic. 

 
 

7. SAP VISUALIZATION 

 

7.1 The following messages appear when both the SAP software and Excel are 

open: “Xcelsius has stopped working” or “Component Busy”. 

 
Possible solutions: 

- Please close any Excel applications that might be open. 
- Open the task manager (Ctrl-Alt-Del) and close all Excel services running in the 

background. 
- Close and re-open the software. 
- Close the software and double click on the .xlf file. 
- Try without internet connection. 

 

7.2 The following messages appear during installation or when opening the SAP 

software: “Script error” or “Runtime Error”. 

 

  
Possible solutions: 

- Before installing the software, ensure that you have unzipped and saved the folder in 
your computer. You should not try to run the .exe file through the zip folder. 

- Before opening the software, right click on its icon and select “Run as administrator” 
(even though the user might be an administrator on the computer) 

- Ensure that Excel is not open 
- Open the task manager (Ctrl-Alt-Del) and close all Excel services running in the 

background 
- Try to install or open the software after closing the Internet connection 
- Ensure all Windows updates have been completed 
- If you have Windows 7, ensure that Service pack 1 is installed 
- If you have Office 2016, ensure that you have Windows Service Pack 3 installed 
- If the error appears before finishing the installation: Uninstall SAP and reinstall with 

only English as language selected. You might want to download an uninstaller 
software. 

- Ensure that you don’t have 2 versions of Office installed 
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- Ensure that you have a genuine version of Windows. The software can’t be installed in 
pirated versions 

- Ensure that you have a genuine and activated version of Office 
- Run an antivirus scan (the issue could be related to malware or viruses) 
- Follow the below steps: 

o Completely uninstall SAP BusinessObjects BI 4.1 -> See attached file 1691555 - 
How to completely remove / uninstall SAP BO BI 4.0 from the system 

o Remove any Microsoft Visual C++ 2005 components currently installed 
o Download and install the Microsoft Visual C++ 2005 Service Pack 1 

Redistributable Package MFC Security Update x86 and x64 executable from 
http://www.microsoft.com/en-
us/download/details.aspx?displaylang=en&id=26347  

o Reinstall SAP BusinessObjects BI 4.1 

7.3 I’m not able to completely uninstall the SAP software. 

 
Here are the instructions for completely uninstalling the SAP software 
 

a. First, the user should make sure that they have backed up all the old dashboard files 
before deleting any folders or registry entries. 

b. Go to Start > All Programs > Control Panel > Add or Remove Programs and 
uninstall all the SAP BO patches in the reverse order. 

c. Select the base install of SAP BusinessObjects BI (SAP BusinessObjects BI platform 
4.0), click on remove. 

d. Once it is finished, reboot the server once. 
e. Remove SAP BusinessObjects folder from <Install Directory>Program Files. 
f. Click on Start > Run > type regedit, which will open Windows registry window. 
g. Right click on “My computer” and take the backup entire registry by clicking on 

export. 
h. Clean the following location in the registry 

i. HKEY_CURRENT_USER\Software\Business Objects 
ii. HKEY_CURRENT_USER\Software\SAP Business Objects 

iii. HKEY_LOCAL_MACHINE>Software>SAP Business Objects 
iv. HKEY_LOCAL_MACHINE\Software\Wow6432Node\SAP Business Objects 

i. Go to C:\documents and Settings\Administrator\Local Settings\Temp. The Local 
Settings folder may be hidden. 

j. Click on enable the option for "Show hidden files and folder" and uncheck the 
option for "Hide protected operating system files (Recommended)". 

k. Backup the Temp folder and delete all the files inside Temp. Don't delete the Temp 
folder. 

l. Go to <operatingsystemdir>\WINDOWS. ( For Example : C:\Windows\) 
m. Search for "Installer" directory and open the directory. If the directory is hidden 

then enable Hidden Folder View from the Folder Option in Operating System. 
n. In the folder view, right click on the columns at the top and select "Author" to make 

that column visible. 
o. Click on the Author column to sort the files by Author. 
p. Delete all the files with "SAP Business Objects" as Author. 
q. Reboot the machine. 
r. Once these steps have been followed, the is ready to do a fresh installation of SAP 

BusinessObjects BI 4.0 /4.1 / 4.2 using the instructions provided in the User Guide 
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7.4 When I produce an interactive dashboard file in PowerPoint, the dashboard 

itself is not visible. 

 
Users might receive the following error message in addition to seeing a blank page: "Some 
controls on this presentation cannot be activated. They might not be registered on this 
computer."  
 
Possible solutions: 

- Click on File->Save as and save it as type "PowerPoint Macro-Enabled presentation 
(.pptm)". Close the file and open the .pptm. 

- Uninstall & reinstall latest Adobe flash player (many times the original installation is 
not properly completed). 

- Export to flash and open the SWF file directly in Internet Explorer (don’t use 
PowerPoint at all). 

 
Remember: the PowerPoint presentation appears only when in slide show/presentation 
mode (click on the “Slide Show” icon on the bottom right of the page). 

 

7.5 When I produce an interactive dashboard file in PowerPoint, I’m able to see 

the dashboard, but the mouse keeps disappearing as I move around within the 

file.  

 
Please install latest version of Adobe Flash Player. 

 

7.6 When I produce an interactive dashboard file in PDF, the dashboard itself is 

not visible. 

 
Possible solutions: 

- The pdf export doesn’t work with Adobe Edge or Adobe Reader X, please ensure that 
you have downloaded and installed Adobe Reader DC. 

- Uninstall & reinstall latest Adobe flash player and Adobe Reader (many times the 
original installation is not properly completed). 

- Usually a yellow bar appears at the top of the page when trying to open the PDF. The 
link in the bar is sending to a page that indicates what needs to be downloaded. Please 
ensure that you have installed the Active X plugin: 
https://helpx.adobe.com/acrobat/using/flash-player-needed-acrobat-reader.html 

 

7.7 My computer already has an SAP accounting system installed on it. After I 

installed SAP Dashboard design software on my computer, I was unable to 

access to open the SAP Dashboard design.  

 
When a computer has already an SAP accounting system installed, it keeps Excel open 
permanently. This causes conflict when opening or installing other SAP software on the same 
computer. 
 
If your computer has already an SAP software installed, we suggest two things: 
 
1. Install SAP dashboard as a new user on the same computer, or 
2. Close Excel from the Start task manager and install the software as a new user. 

https://helpx.adobe.com/acrobat/using/flash-player-needed-acrobat-reader.html
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o Please close any Excel applications that might be open 
o Open the task manager (Ctrl-Alt-Del) and close all Excel services running in the 

background 
o Install the software. 

 

7.8 There is programmatic data entered into the data master for SRs, but it is not 

showing up in the final dashboard.   

 
This occurs because the setting of the number of rows that SAP needs to read from an 
excel input file has not been set correctly. To rectify, open an xlf SAP file, then change 
the number of rows by selecting File-> Select Preferences-> Select Excel 
Options -> Select Maximum Number Of Rows -> Change 512 to 2000 

 

8. GENERIC QUESTIONS 

 

8.1 What are the various versions of SAP dashboard software, and which version 

should I use. Also, where do I download them from? 

 
 4.2 SP3 (latest version): 

https://www.dropbox.com/s/2nnr29vy5jsymit/51051288.zip?dl=0 0r   
https://www.sapstore.com/solutions/99046/SAP-Crystal-Dashboard-Design-2016  
(the access to the SAP link depends on the country of residence) 
 

  4.1 SP6: https://www.dropbox.com/s/aaua1x9u3yq2z8y/51049596.zip?dl=0  
 

 SAP ver. 2011 (version with the tool was designed) 
http://downloads.businessobjects.com/akdlm/dashboarddesign/51044676.ZIP   

 

8.2 Putting interactive dashboards on a website 

 
 

1. Open the dashboard canvas file in SAP (file with extension .xlf) 
2. In the File menu, click on Export and then on HTML (this will take a few minutes):             

File > Export>HTML  
 

https://www.dropbox.com/s/2nnr29vy5jsymit/51051288.zip?dl=0
https://www.sapstore.com/solutions/99046/SAP-Crystal-Dashboard-Design-2016
https://www.dropbox.com/s/aaua1x9u3yq2z8y/51049596.zip?dl=0
http://downloads.businessobjects.com/akdlm/dashboarddesign/51044676.ZIP
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3.  Save the HTML file to a separate folder 

 
 
 

4. Once the HTML file is saved, open the folder where the files are saved; 2 files will 

appear:  
 

5. Open the html file in a web browser to ensure that the dashboard exported properly 
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6. Once you confirm that the HTML file works, add the dashboard it your webpage. This 
process will require IT support as it’s necessary to manipulate the webpage’s code by 
inserting  the dashboard visualization code, which looks as follows: 
 

<HTML> 
<HEAD> 
<TITLE>dashboard_try.swf</TITLE> 
</HEAD> 
<BODY> 
 
<OBJECT classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" 
codebase="http://fpdownload.adobe.com/pub/shockwave/cabs/flash/swflash.cab#
version=9,0,0,0"  
WIDTH="1024" HEIGHT="768" id="myMovieName"> 
<PARAM NAME="movie" VALUE="dashboard_try.swf">  
<PARAM NAME="quality" VALUE="high"> 
<PARAM NAME="bgcolor" VALUE="#FFFFFF"> 
<PARAM NAME="play" VALUE="true"> 
<PARAM NAME="loop" VALUE="true"> 
<PARAM NAME=bgcolor VALUE="#FFFFFF"> 
<EMBED src="dashboard_try.swf" quality=high bgcolor=#FFFFFF 
WIDTH="1024" HEIGHT="768"  
NAME="myMovieName" ALIGN="" TYPE="application/x-shockwave-flash"  
play="true" loop="true"  
PLUGINSPAGE="http://www.adobe.com/shockwave/download/index.cgi?P1_Pro
d_Version=ShockwaveFlash"> 
</EMBED> 
</OBJECT> 
 

Make sure the path to the swf file is correct (text in red).  Add this code to the 
website’s location of choice and you will then see the dashboard displayed on your 
webpage. 
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